请在Chrome、Firefox等现代浏览器浏览本站。记住我们的域名:tmy123.com   加入本站QQ群,大家一起HIGH:点击加入QQ群

IE9以下浏览器访问wordpress网站提示浏览器升级

WP教程 Jophen 俞 2226℃ 已收录 1评论

自2014年4月8日起,Microsoft 不再为 Windows XP 和 Internet Explorer 8 及以下版本提供相应支持和更新。如果你继续使用这些,你将可能受到病毒、间谍软件和其他恶意软件的攻击,无法确保个人信息的安全。由于现在许多wordpress主题不再兼容IE8及以下版本,当使用 Internet Explorer 过期版本(IE6、IE7、IE8 或使用该内核的浏览器)的用户访问时提示浏览器升级。

最终效果:(点击放大)

DEMO

 

实现方法:

把这段代码添加在网站头部代码</head>之前,当IE8及以下版本浏览器(包括使用IE8及以下版本内核的浏览器)访问网站的时候将自动跳转到浏览器升级提示页面。

<!--[if lte IE 8]><script>window.location.href='https://cdn.tmy123.com/IE/%E8%AF%B7%E5%8D%87%E7%BA%A7%E4%BD%A0%E7%9A%84%E6%B5%8F%E8%A7%88%E5%99%A8.htm?referrer='+location.href;</script><![endif]-->

网站在没有兼容的低版本IE中往往都是错版,所以检测到是低版本IE时直接跳转到升级页面,节省了不必要的资源加载,降低了网站服务器开销。去除冗余字符之后,便有了这段简洁优雅的代码。

本站文章如未注明,均为原创丨本网站采用BY-NC-SA协议进行授权,转载请注明转自:https://tmy123.com/7611.html
喜欢 (7)
发表我的评论
取消评论
表情 代码 加粗 链接 私信 删除线 签到

Hi,请填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(1)条精彩评论。
  1. 很好的技巧,谢谢博主了
    wp22014年-11月-29日发表回复| unknow| unknow